Deploy Web Application

I have tried Octopus Deploy tool and we are very happy with it so far. I have one question want to ask you.

We did successfully deploy the IIS Website, but always having trouble with IIS Web Application. I went to your online document, but it only show steps for IIS Website. not IIS Web Application. It always fail us with error on “The application or virtual directory ‘XXX’ does not exist” we had tried many ways, but not working yet. Our server environment are Windows server 2008 R2 with IIS 7.5. Not much sample or document to walk thru on how to create the release with steps that deploy a brand new web application from Octopus deploy.

I hope you can update the document and give more basic examples on how to deploy a web application (again not a website) for both powershell script or from Octopus Web Interface.

Thanks and very appreciated!

Hi,

Thanks for getting in touch! Could you please provide a screenshot of your package step that is causing this error and also a full deployment log:


Generally we see this issue when one of the fields is not being used correctly, and this will give me a starting point to help guide you in the right direction.

Thanks!
Vanessa