'DEPLOY TO' option no appearing in Octopus

I am on version 2020.3.1 and I am not seeing an option to re-deploy a project.
When I click on a release I do not see the option to ‘DEPLOY TO’ or deploy to the next environments.
Not sure what the issue is:

image and I used to be able see it.

And I have the following roles:
Project contributor
Project deployer
Release creator

Hi Mike,

Thanks for getting in touch!

It should appear in the three dots menu e.g.




Hi Paul,
Yes I can see the 3 dots menu but its someone on my team that cant and I am not sure why.


Just to check a few obvious things first, does a hard refresh of the browser (Ctrl-F5) change anything?
And what browser are they using? Can they check it in a different browser too and see if there are any differences?

Lastly, if you temporarily elevate their account to a full admin or similar, does the option appear?


Tried all of the above still no luck.

Hey @mikepower79,

Would you be able to send me a permissions export from the affected user as well as from a user that isn’t experiencing the issue so I can compare please? Feel free to direct message it to me if you prefer for privacy reasons.


Hey @mikepower79,

Thanks for the permissions export.

I added DeploymentCreate to the user role I created to mimic the affected user and the Deploy To… button is now there.

Please let me know if that resolves the issue for you or if we need to dig in a bit more.


Yes that did the trick. Thanks alot.

1 Like

You’re very welcome, thank you for letting me know.

I hope you have a great week.


This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.