Custom Install Directory issues

I’m having a weird issue when using the Custom Install Directory option and deploying a nuget package in a step. It seems to be ignoring my settings and defaulting to C:\Windows\system32#{OctopusPackageDirectoryPath}. I must be doing something wrong here but I’ve used this option multiple times before and it’s worked just fine.

I tried some troubleshooting after reading the documentation. I want the directory to be created ideally but I thought it might not work if I created the directory manually first, no difference. I also tried with and without “Purge this directory before installation” but that didn’t help. Finally I want to point out that I created a release after changing the process, what you see in the screenshot are the settings that were used for the deploy.

Any ideas? I’m on version by the way.

See the attached screenshot for my setup and deployment logs

ServerTasks-12702.log.txt (2 KB)


Thanks for getting in touch! I gathered that you have figured this out as you closed it. But that path means the variable was not expanding which would lead to scoping for where you are deploying while using the variable.


Hi Vanessa,

Yeah, you’re right. While looking into it further, I noticed another user had set up the OctopusPackageDirectoryPath variable in my project! Once I removed that, it was working as I would have expected.