Create release with channel in teamcity

I am using teamcity as build server to build application and create nuget package, then sending package to nuget server, finally triggering octopus to create release and to deploy it use package from nuget server.

In octopus 3.2 pre-release version, when I directly create release on octopus server side, it will find the latest package version from nuget server that be filtered by channel rule. But when I use teamcity and specify channel, it comes error that octopus first get latest package, and then applying channel, so it says this package version violate the channel rule.

How can I tell octopus to apply channel rule before searching package, not to search package before applying channel rule?


Thank you for letting us know that TeamCity was not selecting the correct package when creating a release for a channel.

We have updated the TeamCity plugin so that it will select the latest package that matches the channel rules when you create a release. This will be out in the next Octopus 3.2 release.


Is this issue fixed? Looks like the team city plugin contains a very old version of OctoTools ( that doesn’t actually support the --channel parameter?

Hi Jackie,

That particular Issue was fixed and shipped in Octopus 3.2.0. There is a new version of the TeamCity plugin ( that uses the latest OctoTools ( which added support for Channels.

We are using this version internally and it is working as we expected.

I can see that if I dig around in the file there are a few versions of octo.exe including the latest one. Whilst this might be confusing it shouldn’t cause any issues. If that’s not the case, please get back in touch.

Hope that helps.

Sorry, It’s our fault, picked wrong Octopus version in the build step, changing it to 3.0+ helped.

Hi Jackie,

Glad to hear you got it figured out!

Happy Deployments!