Connectivity issues with azure SQL Managed Instance

Hi all, I have been trying to deploy a .exe app from our bus server. This .exe executes few SQL scripts and needs to connect to an SQL instance. We recently migrated to Azure SQL Managed Instance from SQL Server. During the deployment process, the following network error is observed.

Unhandled Exception: Microsoft.SqlServer.Management.Common.ConnectionFailureException: Failed to connect to server az-sqlmanagedinstance-dmuat.ec19f487cbba.database… —> System.Data.SqlClient.SqlException: A network-related or instance-specific error occurred while establishing a connection to SQL Server. The server was not found or was not accessible. Verify that the instance name is correct and that SQL Server is configured to allow remote connections. (provider: Named Pipes Provider, error: 40 - Could not open a connection to SQL Server) —> System.ComponentModel.Win32Exception: The network path was not found
— End of inner exception stack trace —

  1. We have enabled all the necessary firewalls from our bus server.

  2. We are able to connect to the SQL Managed instance using SSMS.

  3. Enabled TCP/IP connection

  4. Created an exception for port 1433 in Windows Firewall.

  5. Able to ping the SQL Managed Instance from the server.

What else can I do here?

Hi @hjulapelli,

Thanks for getting in touch! From what you’ve described it looks like that should normally be enough. Might be worth confirming it’s using the default port 1433? Do you have anything else sitting in between the connection, like proxy, that needs to be taken into account? Would you be willing to send through the full task log where you’re seeing this error? I’m hoping that provides a bit more context around this issue. Feel free to mark this thread as private, or send it via email to and we can pick it up there. :slight_smile:

I hope this helps for now, and I look forward to getting to the bottom of this one.

Best regards,


This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.