Connection string

Trying the following connection string:

Data Source=.\SQLEXPRESS;Initial Catalog=Octopus;Integrated Security=True

On “Save and Test” I get

Octopus Configuration

Error connecting to the database: Login failed for user ‘’.


I am a domain user, not a regular user, if that helps. (I also tried the user and password instead of integrated security, same error message.)

Data Source=.\DEV;Initial Catalog=Octopus;Integrated Security=True;MultipleActiveResultSets=True

It works for me. Have you created empty database ? Do your user have permission to access that Octopus database?

Yes to both; I could connect to it from within Visual Studio without any problem.

HOWEVER - the error happened while running the server tools on the initial install. I tried running the program again, to add the MultipleActiveResultSets setting, which I didn’t have, and it works both with it and without it. I don’t know why… anyway, problem solved :slight_smile:

Does it work if you use:

…Integrated Security=SSPI


I tried that during the install, but it didn’t work. However, as I said, after I closed that window and re-launched the program about 20 minutes later, it suddenly worked. I have no idea why, unfortunately.

I had similar problems, a restart helped me too…

Aha, the restart issue was caused by the connection string being cached :slight_smile: It’s fixed in the latest build: