Config transforms not applied when deploying project

So I’ve finally come to ask the question here as reading other related answers has still not resulted in success. I am unable to get any XML transformations applied to my config files in a project I am deploying. It’s a windows service, and I’m trying to configure the mail settings, but they are never set properly, and there is no step in the OD log to indicate it has tried to apply a transform at all.

I have XML transforms ticked, and I additionally have the following custom transform:
App.#{Octopus.Environment.Name}.config => My.Service.exe.config

I also tried it with:
App.#{Octopus.Environment.Name}.config => App.config

Under ‘Configure features’, I have ‘configuration variables’ and ‘configuration transforms’ ticked, but not ‘substitute variables in files’.

What am I missing?

Hi Pierz,

Thanks for getting in touch! After you made the changes to define those files did you create a new release? Are both files in the same directory as each other?
Those are generally the most common mistakes. Otherwise if you could provide screenshots of your project process, screenshot of those settings, a full deployment log, and a screenshot of your package where those files are we might be able to get to the bottom of it.

Hope that helps!