Changing from -webAuthenticationMode from UserNamePassword to Domain

to change to domain mode for the octopus.server.exe

Where i already have a server setup for UserNamePassword do i just pass the domain switch or is there more to it?

do I just need to run this:
-webAuthenticationMode Domain?

Is there anything else I need to do I see these extra switches are present:
Octopus.Server.exe" configure --instance “OctopusServer” --home “D:\Octopus2\test-domain” --storageMode “Embedded” --upgradeCheck “True” --upgradeCheckWithStatistics “True” --webAuthenticationMode “Domain” --webForceSSL “False” --webListenPrefixes “http://localhost:80/” --storageListenPort “10931” --commsListenPort “10943”

compared to the initial install:
Octopus.Server.exe" configure --instance “OctopusServer” --home “D:\Octopus2\test” --storageMode “Embedded” --upgradeCheck “True” --upgradeCheckWithStatistics “True” --webAuthenticationMode “UsernamePassword” --webForceSSL “False” --webListenPrefixes “http://localhost:80/” --storageListenPort “10931” --commsListenPort “10943”

Hi Thom,

Thanks for getting in touch!

There are two important steps to changing the authentication mode, the first as you have found is webAuthenticationMode, but the second is setting the new admin user.
The documentation and example can be found here:

Hope that helps!