Can't select a Client Certificate for Service Fabric

I’m trying to deploy a Service Fabric application to a cluster that is secured using certificates. But I’m unable to select a client certificate as the drop-down list doesn’t have any options, even though I have some variables created for the project. Is there anything special I have to do to make things appear in the drop-down list? I’ve also tried setting a custom expression but nothing I’ve tried seems to work.

Every time I try to deploy, it fails with an error “Failed to find a value for the client certificate.”

I’ve also tried setting the Octopus.Action.ServiceFabric.CertificateFindValueOverride variable but it still fails with the same error.

I forgot to mention, this happened on version 3.13.5 and 3.13.8.

Hi Jeremy,

Thanks for getting in touch.

Could you please confirm whether you’ve created certificate variables for your project? The variables have to be of type “certificate”.

For example, in your project variable’s list, in the Value field, you click “Show editor” where you can then choose a variable type from a dropdown. Select “Certificate” and you should see certificates that are managed by Octopus (as shown here. Note that once saved, certificate variables are displayed with a little certificate icon next to them.

Once you save those changes in your project variables page, that certificate variable should then show up in your Service Fabric step’s dropdown list.

Let me know how you go.


Thanks! That works perfectly. TIL that variables in Octopus can have types :slight_smile: