Can't install to Windows Server 2008 R2 SP1

No matter which package I try to install, it always says “The version of this file is not compatible with the version of Windows you’re running.”

.NET 4.5.2 is installed, 64 bit Windows Server 2008 R2 Datacenter SP1. I’ve tried the 32 and 64 bit installs. I’ve tried the 3.3.24 version installer (to match all our other tentacle versions). No go. Am I missing something?

Event log states:

The program or feature “??\C:\Users\MYUSER\Downloads\OctopusTentacle.exe” cannot start or run due to incompatibity with 64-bit versions of Windows. Please contact the software vendor to ask if a 64-bit Windows compatible version is available.

Hi Josh,

Thanks for getting in touch. That’s a strange error. Any chance that’s an Itanium-Based Systems where you’re running Server 2008?

Anything else different about this server compared to any others you have where you’re not seeing this issue? Could you send a screen shot of the Control Panel\System and Security\System window. Would you also mind sending through a screen shot of the installed feature set on the server, expanding all the sub menus?

Also could you let us know which other version you tried, you mentioned 3.3.24 did you try a more recent version too?


It’s a barebones installation, setup just to run a windows service we developed.

I also tried the latest installation (whatever that is) - 3.14 I think

Nevermind, I’ve been staring at this too long. My powershell script downloaded your MSI as an exe. Carry on. Pay no attention to the man behind the curtain.

No problem Josh :slight_smile:

Hope it all goes smooth after this, let us know if you have any other issues.