Can't get the "Deploy" step to work except manually

Hello - making a switch from a locally managed instance of Octopus to the paid cloud version, and it seems like all is well except the very last step, which is the actual deployment.

If I go under releases > {releaseNumber} > Deploy, the deploy goes without a hitch. But when I run the release through our VSTS release pipeline, it doesn’t actually deploy. That last step just doesn’t happen.

The puzzle is that VSTS says it has deployed, and I get no errors.

What step(s) am I missing? What information do I need to provide to help move this to getting an answer plus a working automated build/deployment scheme?

Thanks for your help!


PS - I tried to add this to the “Execution” forum, but it seems that someone else will move this to the proper category.

Hi Russell,

Thanks for getting in touch. Would you be able to check the build log details in VSTS to verify the service connection details it is using? If you are switch Octopus instances, I’m wondering if it is somehow still using the connection details to the locally managed instance rather the cloud instance.

Regarding the forums, yes this is by design. New posts go into the Support forum and we have an operations team who triage and get them to the team who can best help. This one came to Integration for example, because we specialize in the integrations from all of the build servers, whereas Execution specialize in how Octopus (i.e. Calamari) actually executes the deployments. Hope that helps clarify.


Figured it out: there is a “Deployment” setting that I didn’t see before in the “Create Octopus Release”… Thanks for your help!

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.