Can't access Octopus Server using public IP


  • I have just setup a new AWS instance
  • teamcity is bound to port 82
  • octopus bound to port 81 (only on localhost)
  • i have added a security group that allows traffic via port 81 and 82
  • both teamcity and octopus work using their localhost addresses
  • only teamcity work using x.x.x.x:82

octopus keeps responding with: This site can’t be reached

what else can i do to try and diagnose the issue here?

Hi Mark,

Thanks for getting in touch! We are going to need a little bit more information to settle this one.

Can you confirm that when you added this you updated the bindings in Octopus for that IP address?
I have attached a screen shot that shows where you can do this in the Octopus manager.

If you are using HTTPS, you can get a bit more info from our documentation over here:


Hi Daniel

I just resolved this. The problem was in windows firewall.

TeamCity automatically added exceptions so worked straight away.
Since Octopus doesn’t… it didn’t

Because TeamCity worked i dint think to look there

I know you can’t protect users from themselves or predict all possible scenarios but it would be great if the octopus manager was able to do / detect some of these types of things for us


Hi Mark,

Thanks for getting back! I’m glad to hear that it is working for you now. I agree that there are some areas where we can definitely do better. Thanks for pointing it out, it is something we will keep in mind for the future.

Let me know if you run into any further issues or have any more questions.



This issue has been closed due to inactivity. If you encounter the same or a similar issue and require help, please open a new discussion (if we asked for logs or extra details in this thread, consider including them in the new thread). If you are the creator of this thread and believe it should not be closed let us know via our support email.