Cannot sign in (v3.5)

just upgraded from v3.4.11 to v3.5, and now cannot sign in. after entering userid/pw and clicking “sign in”, it reports a 404 error. also, graphics are not rendering.

screen shot attached.


Hi Mike,

I have had a similar report where this was occurring in IE but not in chrome. Which browser are you using and could you confirm that behaviour?

Thanks. And sorry for the troubles.

using chrome. trying IE…same result.

We experiencing exactly the same issue too.

I can use Octopus until I log out. Then afterwards, we cannot log back in. This is a serious issue for us.

Could you both send through the most recent server logs (c:\Octopus\Logs).
Feel free to send it to support @


Sorry if you could also provide the results for the following command on the database that would greatly help:

select * from [ExtensionConfiguration]

Thanks again

In the mail.



if there is no fix soon, could we downgrade back to v3.4.11 (or .15)? or have there been non-reversible changes?

We are just writing up a downgrade guide. Did you backup the database before the upgrade?

I have been considering this as an option and have already tried installing
3.4.15. This resulted in the server just shutting down.

Do I need to uninstall the software and re-install?
Would I need to rollback the database?

I believe our backups are very flexible with it being hosted on Azure. I
just need to work out the best time to rollback to.

HI Brian,

To rollback you need to both reinstall the previous version MSI, and restore to the backed up database. One or the other won’t work unfortunately. You will also need to add: <set key="Octopus.WebPortal.AuthenticationMode">0</set> back to your Octopus.Server.config as it was moved to the database on the 3.5 upgrade.

Note: a value of 0 is for user/pass and a value of 1 for AD, as you were user/pass the above is correct for you, but if anyone else finds this thread you need to use the correct setting.

We believe this should be enough to get you back to the previous version.



Similar instructions above except as you were using AD your value would be 1 for that line added to the config file.


if we downgrade to 3.4.x, will tentacles that have upgraded to 3.5 work properly?

Yes absolutely. Tentacle upgrades are no longer required and parity is no longer needed between both Tentacle and Server.

Calamari will take care of itself.

Please keep me updated, pushing 1am here and I would love to know you are back up and running before I crash.


So, I have done the following:

Re-installed 3.4.15 using both, re-install over top of 3.5, and the uninstall and re-install options.

Testored the app setting in Octopus.Server.config with 0 for non-AD authentication.

Rolled back the database, an hour at a time, because I am not absolutely sure of the time that I upgraded.

Login page fails to load. When I attempt to load the login page, the server is immediately shut down (within Manager) afterwards.

Hopefully, this issue is because the database has not yet been rolled back far enough. However, I am doubtful of this.

Update, no sooner had I posted the message, had another rollback completed, and all seems back to normal.


Starting the downgrade down. Will keep you updated

Downgrade successful. Get some sleep.

Look forward to v3.5.1. :slight_smile:

From: Mike Jacobs
Sent: Friday, November 4, 2016 12:13 PM
To: ‘Vanessa Love’
Subject: RE: Cannot sign in (v3.5) [Problems #48648]

Starting the downgrade down. Will keep you updated


we’re having this issue, but our database backups don’t go back far enough. (i’m looking to see if our backups are backed up!).

Is there a fix coming for this shortly?