Cannot login with new username

Hello I have a very strange problem.

I want to create a new user in Octopus, just for testing.
I don’t want to create this user in our AD.
So I created filled this form.
Configuration -> Users -> Add Users ->New User
• Username: erictest
• Display Name: erictest
• Service Account: This is not a service account
• Email address: (my own email address)
• Password: I added a password
• Active Directory: No loins are associated
• Then I added the user to the team ‘Octopus administrators’
If I try to login with erictest (and I tried different passwords) I always get the error:
There was a problem with your request.
Invalid username or password.
Can you tell me what is going wrong here? What do I forget?
Eric Bosman

Hi @ebosman,

Thank you for contacting Octopus Support.

Since AD auth is enabled, it sounds like username and password authentication may be disabled. You may re-enable this by using the command line with the following command:

Octopus.Server.exe configure --instance=[your_instance_name] --usernamePasswordIsEnabled=true

More info here: Username and Password - Octopus Deploy

Let me know that works for you.

Best Regards,

Thank you, this works.

1 Like

Hi @ebosman,

Thank you for getting back to me. I’m glad to hear that worked for you.

If there is anything else we can assist with, please let us know.

Best Regards,

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.