Cannot create a file when that file already exists #2


I get the same error as in . “Cannot create a file when that file already exists”.

I have verified that I have only one site in IIS, and that’s the only one running on port 80. The WebSite runs fine after deploying with the correct version and IIS setup, but the portal says that the deployment failed due to that “file” already existing.

Setting it up manually in IIS to the deployed app dir and on port 80 works, and I’m able to browse to it.

I tried to remove all Sites in IIS, and let Octopus create it from scratch, but same error occurs.

Running Octopus

What gives?


Thanks for getting in touch. Couple of things:



Yep, will provide logs and netstat tomorrow!

Switched to port temp 81 temporarily, and that worked.

Also, deploys to port 80 works if I provide a hostname.


Proto Local Address Foreign Address State PID

PS C:\Windows\system32> Get-Process -Id 4

Handles NPM(K) PM(K) WS(K) VM(M) CPU(s) Id ProcessName

2999 0 108 284 3 14,59 4 System

I have the Web Management Service running on 8172 and have Web Deploy installed on the same server.


Sorry for the delay! The error Cannot create a file when that file already exists usually that there’s a bindings conflict, and there is already a site running on the same IP address, port and if you’re using them, hostname. Can’t say for sure where is the duplicate binding that is causing this conflict, but providing a hostname seems to have worked, and I it sounds like a valid enough workaround :slight_smile:

Best regards,


1 Like