Calamari runs NPM command after unpacking NuGet

We are running a simple “Deploy A Package” step on a Windows Server 2019 instance. The NuGet package contains a few npm packages. When Calamari unpacks the files, it correctly copies over the 80 files… then it tries to run some NPM command (not sure what it is trying to do on the deploy-package step). This causes an error because there are NPM warnings (it always fails on the first NPM warning).

The same setup on Windows Server 2012 works perfectly fine. The tentacle is old it is 3.24.0.

We are using a slightly older version of Octopus v2018.10.0 LTS, the tentacles are 5.0.9.

I have given the tentacle a service account for when I run the deploy.ps1 file as well as NPM commands with. These commands work fine when logged in as the service account.

The Octopus directory on the E: drive as well as where it copies to are given full access by the service account under Windows Permissions.

The same error occurs if the Tentacle is installed as “Local Service Account”.

Error from Tentacle:

Hi @jcavanaugh,

Thanks for getting in touch! I’ve seen similar errors in the past where the warning is parsed as stderr. If this is the case here, you could redirect the message to stdout (as shown here) or you could configure npm to suppress the warning (as shown in the answer in this Stackoverflow thread).

If that’s not the case for your scenario however, would you be willing to send us through the full task log? There should be more info above what’s shown in your screenshot to give us a better idea of what’s going on. :slight_smile:

I look forward to hearing back and getting to the bottom of this one!

Best regards,


1 Like

So the trick was a couple things, one was to increase the timeouts and the other was to shut off the warnings as you had indicated. Interestingly enough, on Windows Server 2019, I would also suggest using a service account with the tentacle (if it needs to reach out to NPM like this one does) as the default system user will likely not work (depending on your setup).

Thanks for the assistance!

Hi @jcavanaugh,

Thanks for keeping in touch and detailing your solution! It might help someone in the future in this same situation, so it’s much appreciated. :slight_smile:

Don’t hesitate to reach out if you have any questions or concerns in the future.

Best regards,