Calamari Extension gets a suffix of .000

I’m using Octopus version 3.16.2. We recently had a failed deployment where deploy package step didn’t fail, but didn’t complete either. When I say didn’t complete, there wasn’t a log of how many files were copied, nor did the post-deploy script run, but It still showed successfully. I only know it failed when it tried to start the deployed services and failed there.

I tried to run a script from the script console to diagnose the issue, and I get a message saying calamari doesn’t exist. I went to the server and saw the application got renamed to Calamari.exe.000. I left that file, and copied another Calamari.exe, which after another deploy got renamed to Calamari.exe.001.

Is the tentacle rename the calamari extension as a file lock?

Hi Zovin,

Thanks for getting in touch!

Looking at your description of events it appears that your antivirus software is quarantining Calamari.exe. Are you able to exclude the Octopus folders from your antivirus scans and advise if the issue continues?

If you can advise which AV vendor and software version that you are using so that we can follow up with them to identify the cause that would be very much appreciated.

Please let me know how you go, and feel free to get in contact if you have any other questions or queries.



Hey Alex,

Sorry for the late response. We’re using Octopus to deploy to our client’s servers, so it took a little while to get connected to the client.

They are using a Trend Micro product that’s managed by an external company. In their logs, it listed Calamari.exe as a virus program and immediately tried to delete the moment it runs.
I’m waiting to for them to whitelist the folder to test and ensure no other conflicts happen.

Hi Zovin,

Thanks for the update, glad that we have identified the problem!

Let me know if you have any other issues,