Bug when selecting container registry in the Kubernetes Deploy Containers template


I’m currently encountering a bug in Octopus Deploy v2019.11.1. I have this version installed on prem. The issue is related to selecting the container registry in the Kubernetes deploy template. The following are the steps to reproduce it:

  1. Have an external container registry setup in External Feeds (I have both https://index.docker.io and https://myregistry.azurecr.io registries setup)
  2. Go to any project
  3. Go to the Deployment Process page
  4. Add a new Deploy Kubernetes containers step
  5. Go to the Containers section an click on “Add Container”
  6. Go to the Package Image section of the pop up and select a Package feed
  7. This will result in the following error: An unexpected error occurred in Octopus v2019.11.1: "Error: Minified React error #185; visit https://reactjs.org/docs/error-decoder.html?invariant=185 for the full message or use the non-minified dev environment for full errors and additional helpful warnings. "

My local setup reproducing this error is:

  • OS: Microsoft Windows 10 Enterprise Version 10.0.17134 Build 17134
  • Browser: Chrome Version 79.0.3945.117 (Official Build) (64-bit) – i.e. the latest Chrome version

The server Octopus Deploy is installed on is:

  • OS: Microsoft Windows Server 2016 Datacenter 10.0.14393 Build 14393

This is currently blocking me – a workaround would be ideal. Or if it is a known issue, though I couldn’t find any references to it, is it fixed in a later version and a server upgrade would fix the issue? Though we just upgraded our server version so a workaround would be much more preferable.

Hi @peadar,

Thanks for getting in touch!

This was an issue that was discovered in that version. Most of the dropdowns on that section resulted in the same error.

It has now been fixed in 2019.11.3 so a server update would be your best option.

Best regards,

It has now been fixed in 2019.11.3 so a server update would be your best option.

Oh well, I guess we need to update the server again. Thanks for the quick response @paul.calvert.

1 Like