Bamboo addon - create release fails - API key error

Using the bamboo addon for Octopus deploy, I get these errors:

09-Feb-2019 17:45:52 Publishing database package to ‘http://localhost/nuget/packages’.
09-Feb-2019 17:45:52 Published ‘TestSCA.1.1.0-build17 SQL Change Automation Build Artifact’ to ‘http://localhost/nuget/packages’.
09-Feb-2019 17:45:53 Octopus Deploy Command Line Tool, version 4.45.0
09-Feb-2019 17:45:53
09-Feb-2019 17:45:53 Detected automation environment: “Bamboo”
09-Feb-2019 17:45:53 The API key you provided was not valid and doesn’t start with “API-” as expected. Please use the entire API key which should look something like this “API-…”. For instructions on finding your API key, please visit:
09-Feb-2019 17:45:53 Exit code: -5

I am using the exact same API key that I am using for the publish task, and I’ve copied the key several times into the create-release task, but it keeps giving me this error.

Oddly, I tried one more time by copying it from my password manager and it worked. Confused - wondering if it was erroring because it was being copied from a word doc and in bold. Perhpas it needs to be plain text?

Hi Peter,

Thanks for getting in touch! It’s possible it was because it was copied from a word doc in bold, or maybe the prefix API- in the API key wasn’t included? Either way, great to hear you got it resolved! Don’t hesitate to reach out if you have any questions or concerns moving forward. :slight_smile:

Best regards,


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.