Azure DevOps Integration (Metadata & Widget)

I have recently upgraded to Octopus OnPremise 2019.8.1 and have encountered 2 issues in regards to integration with Azure DevOps (Which is also OnPrem hosted on the same machine).

  1. After the changes to introduce Spaces to octopus none of the Octopus dropdowns in Azure Devops are loading, e.g. the dashboard widget & build pipeline tasks.
    While I can get around the build pipeline issues by manually typing dropdown values (not a nice experience), the widget dropdowns cannot be manually entered and so are completely broken (See the below gif).
    This issue was also present on the current LTS version of Octopus, as I upgraded to the fast lane in hope that it had been fixed.


  1. I can’t get the work item integration between Octopus and Azure DevOps to work for the automatic release notes.
    While the packages metadata seems to be pushed okay (I can view it in the package library), I cannot view it from the release screen as seen in several of the documentation screenshots ( - And I cannot get the release notes to generate using the example templates given, such as

#{each workItem in Octopus.Release.WorkItems}
#{workItem.Id} - #{workItem.Description}

I’ve tried to follow everything on the following pages;

Am I missing something? What can I try to resolve these issues?

I have the exact same issue. Prior to updating to v2019.6.8, the ‘Spaces’ showed up but the drop downs etc still worked. After the 19.6.8, they do not. I cannot select the Project, Deploy to Environments, pretty much anything that I should be getting from the server.

I am running the latest release of TFS18 and Octopus on the same server.

I really need a solution to this problem.


Hi @TroyHouston and @gswanson,

Thanks for reaching out. I’m sorry to hear you both are running into this issue.

As soon as you click on Configure to setup your dashboard, a couple of calls to an endpoint called ServiceEndpointProxy are going to be made as shown on the below screenshot.

I’m gonna need to ask you both to check the URLs of those calls and the JSON in the response, and add that info to the attached spreadsheet

ServiceEndPointProxyReport.xlsx (5.3 KB)

After you send me that info, I’m probably going to get back to you with a few more questions, so I think the best approach will be for you both to email me that spreadsheet to so we can have separate communication channels for each of you.

In that email please also include which version of the Octopus extension you are using in your TFS/ADO extensions.



Thanks for your reply, but this isn’t taking me down a successful path. I am using TFS18 not Azure DevOps and the UI is quite different. I cannot find an equivalent place to get the information that you are requesting. See below.

Secondly, this is not a new installation, but an existing installation that has been working for over a year until I installed the latest update to Octopus.

Regarding the version of the Octopus extension in TFS, how do I find that version number? I notice that there was a new release on the 3rd, but how does that get updated in TFS?

There are no options for Get Information, Update, etc… From the Octopus Admin side, it is able to track and update the tentacles, but doesn’t seem to be aware of the TFS integration.



Hi @gswanson,

I saw you are having a similar conversation with my mate David via email. He and I are working together on this. So if it’s OK with you, I’ll continue working with Troy in this ticket and you can keep working with David on the other channel.

Since you and Troy are using different build servers, I think its gonna be best to keep the conversations separated.


Sounds great, thanks!

1 Like

Sorry for the delay, I was out of the office for a few days last week.

I’ve attached the requested data below,

TROY-ServiceEndPointProxyReport.xlsx (12.8 KB)

Octopus Server Version - 2019.8.1
Extension Version - 4.0.385

Let me know of any other information you require.

Hi Troy,

We released 4.0.387 two days ago which includes a bug fix related to spaces that might be what related to your issue. Is there any chance you can upgrade to that version and give it another try?


I upgraded to the latest version, but unfortunately no change - Seems to be the same failure from the api calls

Hi Troy,

Issue 1. Those responses in the spreadsheet look most consistent with Azure DevOps being unable to establish a network connection to Octopus. Usually this is caused by a firewall, a missing network route, an unresolveable hostname, or an SSL problem (such as a certificate problem). Note that these connections are made from the Azure DevOps server directly to Octopus.

It’s unusual to see most of those within a single machine, although I do see more than one hostname involved - do both hostnames resolve locally?

Issue 2. Work item integration needs a few things in place to work. Please check the following:

I hope that sheds some light on things. Please let us know if we can be of further assistance.


1 Like

Thanks for the reply,

This one is now fixed, there were some issues with internally resolving the hostname of octopus on the server. This was resolved by adding a HTTP binding and forcing redirects to the HTTPS binding (previously there was only a HTTPS binding)

It seems that the metadata is now working when I manually create a release.

  • The only change I did was to provide Octopus with a DevOps API key that had full permissions, perhaps it requires more than the two that are documented? (read scopes Build and Work items)

  • However the releases that come from DevOps via the octopus extension always force their release notes (I can’t find a way to turn them off) and so the automatic release notes can’t be used unless the releases are created manually.

Hi Troy,

Thanks very much for investigating this and identifying the issue with the --releaseNotesFile argument.

A fix has been shipped today in version 4.0.395 of the extension. That should automatically apply if you installed it from the marketplace originally, but it’s also available here:

It will now avoid sending --releaseNotesFile if those 3 legacy “Release Notes” options are cleared, which will allow your release notes to be generated from the Release Notes Template you define in Project settings. Instructions and a Work Items example are available here:

Sorry for the inconveniences. Please let us know if that hasn’t solved it, or if there’s anything else we can help with.


David Young.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.