Azure ARM Deployments to App Services

We have been using Octopus Enterprise for over a year now with no issues(Version 3.3.8) deploying to cloud services in old Azure ASM or classic portal. We recently moved over to the new portal using App Services and have been having issues ever since. I opened up a ticket with MS and they said we need to start using new Powershell commands and that the ones we are using are far outdated. Also with the new portal, they don’t have management certificates like the classic portal did and have a new way to allow deployments. The old methodology worked great for the old environment, but I was hoping you guys might have some documentation or suggestions on how to make these new deployments play well with Microsoft’s new portal. Any help or suggestions would be greatly appreciated since MS wont really help us until we update our commands. For example we currently use “New-Azurewebsite” and MS recommends we use “New-AzureRmWebApp”.



Hi MP,

Thanks for reaching out!

Have you tried using our built-in support for Azure apps? Its a bit easier than having to write your own scripts:

Let me know if that helps.