Automatic Tentacle installation and register-with in v2.0

I’m trying to evaluate your tool for our company. We have 500+ servers to which we’ll need to deploy our code and have to be able to script the deployment of the tentacle services to those servers. On the positive side, the tests I’ve run after manually installing a few tentacles seem to indicate that this tool will fill our needs. On the not so positive side, I’m stuck on an issue with the automated tentacle install.

Using this command throws an error (obviously I removed our specific info):
tentacle.exe register-with --instance=“Tentacle” --environment=“Development Stack 01” --role=“WEB” --server=“http://myservername/octopus” --apiKey=API-BLAHBLAHBLAHBLAH


A fatal exception occurred
Octopus.Client.Exceptions.OctopusValidationException: There was a problem with y
our request.

  • An HTTPS address must be supplied for the machines’s URI

    at Octopus.Client.OctopusClient.DispatchRequest[TResponseResource](OctopusReq
    uest request, Boolean readResponse) in c:\TeamCity\buildAgent\work\1116bd9da9e23
    9fd\source\Octopus.Client\OctopusClient.cs:line 414
    at Octopus.Client.OctopusClient.Create[TResource](String path, TResource reso
    urce) in c:\TeamCity\buildAgent\work\1116bd9da9e239fd\source\Octopus.Client\Octo
    pusClient.cs:line 141
    at Octopus.Client.Operations.RegisterMachineOperation.Execute(OctopusServerEn
    dpoint serverEndpoint) in c:\TeamCity\buildAgent\work\1116bd9da9e239fd\source\Oc
    topus.Client\Operations\RegisterMachineOperation.cs:line 110
    at Octopus.Tentacle.Commands.RegisterMachineCommand.Start() in c:\TeamCity\bu
    ommand.cs:line 95
    at Octopus.Shared.Startup.ConsoleHost.Run(Action`1 start, Action shutdown) in
    oleHost.cs:line 35

Any help would be appreciated.

Hi Paul,

Have you decided whether you’ll be registering these as listening Tentacles, or polling Tentacles?


Listening. And I tried adding “–comms-style TentaclePassive” to the register-with line and got the same error.

I set it to TentacleActive and it worked. When, from the Octopus server, I tried to change the Tentacle from Polling to Listening the Tentacle URL comes up as http instead of https. How can I make sure that writes as https? That seems to be the root issue.


Sorry for the delayed response. This is a bug in the register-with command (we are forcing HTTP because that’s what Octopus 1.0 used). We’ll fix it and release a new 2.0 build today.


Thanks. I’ll watch for it to be posted.

Any update?


A new build of Octopus 2.0 is out which should fix this issue:

Thanks for the bug report,


That fixed it. Thanks!