ARM Template deployment fails when parameters file contains Metadata

OD version: 3.11.5
Calamari version: 3.4.4

When deploying an ARM template using a parameters file that contains description metadata the deployment fails with:

InvalidRequestContent: The request content was invalid and could not be deserialized: ‘Could not find member ‘metadata’ on object of type ‘DeploymentParameterDefinition’. Path ‘properties.parameters.deploymentScope.metadata’, line 129, position 20.’.

This is using the 'Deploy an Azure Resource Group step template.

Deploying using the New-AzureRmResourceGroupDeployment PoSH Cmdlet is successful. Once the metadata was removed from the parameters file the OD deployment completed successfully.

Sample parameters file and deploy log attached.

azuredeploy.parameters.json (621 Bytes)

ODArmMetaDataFailLog.txt (5 KB)

Tried updating the tentacle to use Calamari version 3.11.5 but get the same error.


Thanks for getting in touch! I’m sorry for the delay in getting back to you.

Since your deployment in PowerShell was successful, it may be due to the Azure modules which are bundled with Octopus, as they are used by default. Can you override the bundled version to use the version installed on your server? You can do that by setting the following variable in your project: Octopus.Action.Azure.UseBundledAzurePowerShellModules with a value of False, then create and deploy a new release. You can reference this Azure module version configuration in our documentation.

If that doesn’t help, we’d like to try reproducing this to figure out why your deployment is failing. Would you be able to attach the ARM template itself, and the parameters file that fails?

You can also make this thread private if you send sensitive information :slight_smile:

Kind regards,