Anybody know why Octopus.Server.exe help command is so slow?

When I’m running Octopus.Server.exe help commands it can take from 5-10 seconds to display the relevant help information.
Just wondering why it takes so long to echo out help information.

Regards Alex

Hi Alex,

Thanks for getting in touch. I just tried it on 2 machines, being the one with fewer resources an Azure VM with 1.5GB RAM and 1 shared core and it took less than a second to run. Not sure what might be going on on your end.

Are you experiencing any other kind of slowness running Octopus on that server?


Ok thanks for that, must just be my setup then.
I’m running a VM on VMWare VSphere with 4GB ram and 2x2ghz processors.
I just timed the octopus help command and it took 23 seconds to return the help info.
A part from that octopus is working fine on this server. Just thought I’d check and see if any one had similar issues and had a fix.

PS E:\Octopus Deploy\Octopus\Install> Measure-Command {.\Octopus.Server.exe help}

Days              : 0
Hours             : 0
Minutes           : 0
Seconds           : 23
Milliseconds      : 234
Ticks             : 232348368
TotalDays         : 0.000268921722222222
TotalHours        : 0.00645412133333333
TotalMinutes      : 0.38724728
TotalSeconds      : 23.2348368
TotalMilliseconds : 23234.8368

I have the same issue too, server exe version … It takes quite a while for any command to execute, whether the service is running or not.

Edit: I am also running Octopus on a VMWare server, running Server 2012


Which command are you trying to run on just Octopus.Server.exe help or something else?



Hi Dalmiro,

Any command I’ve tried hits that timing. I just now tried the help command for fun and it has the same delay (about 20-30 seconds).

Let me know if there is anything I can try or run for you.


I’m gonna have to use those dreaded words: We can’t reproduce it on our end. Unfortunately unless we can do it, we cannot work on a fix for this :(. We’ve check the code behind the console startup to see if there was something funny going on, but we found nothing that would justify a 20sec delay.

We will keep our eyes open to see if more users run into this issue, and if that happens we’ll try to figure out if its an environmental issue or something in our code.

Sorry for the crappy news


Hahaha, no problem! Believe me, I understand, and the issue is definitely not stopping me from buying a license. Thank you for looking though!

Had a similar problem when automating installations in an environment that did not allow outgoing internet access. Turns out the delay was from Windows trying to update its root certificate list, which happens pretty much any time you do Octopus stuff (due to checking publisher / signatures or something.)

We set the following two registry keys to stop Windows from doing that (since it was going to time out anyway), at which point all of our Octopus commands started responding quickly:

HKCU\Software\Microsoft\Windows\CurrentVersion\WinTrust\Trust Providers\Software Publishing\State = DWORD:146432 (or 0x00023C00)

HKLM\Software\Policies\Microsoft\SystemCertificates\AuthRoot\DisableRootAutoUpdate = DWORD:1

Dave - Thanks for the tip :slight_smile: