After installation octopus thinks database is out of date


After installing Octopus on my machine the web interface greets me with:

  • Database upgrade required *

Following the instructions provided on that page does not help
because the configuration tool says the database is up to date.

Any idea on how to fix this?

Version info from the installer: 0.8.382.1995

Off course I saw this post only after I upshed the submit button.

the problem was security related.
I couldn’t get windows authentication to work (granting access for NT AUTHORITY\SYSTEM or NT AUTHORITY\NETWORK SERVICE to the Octopus database didn’t work) but specifing a user and password in the connection string worked.

Please consider letting the installer do the dirty work of setting up the database and its accounts and permissions.

I am having the same issue and on inspecting the database it has no tables created. The configuration tool says that the database is up to date and the portal says that the DB needs upgrading.

Hi Remco, Dave,

I am working on a fix for this and should have something out in a few hours.


After some investigation, it was a security issue.

The web-app (or service) could not connect to the database, (even after adding NT AUTHORITY\NETWORK SERVICE and NT AUTHORITY\SYSTEM to the allowed users)

I solved it for by adding a sql login and adding user and password to the connection string runs for cover

Thanks Remco, that’s usually the underlying problem (IIS runs under a different user context than the tool, which explains why the tool works and the site doesn’t), but the error page masks this by not showing the error.

This new build will show the error details if there is a problem connecting:

Glad you resolved your issue,


Works for me too.

I cant wait to try this out, awesome effort.

Great, thanks for the update!