Add deployment target fails with 'The link is not set to a value' error


I recently upgraded from 2018.1.3 to 2018.10.1, during the install process I was prompted to locate the 2018.1.3 MSI and so downloaded a copy and pointed the installer at it. After this the installer finished without reporting any issues.

However, now when trying to add a new deployment target the page fails to load with the following error message:

An unexpected error occurred in Octopus v2018.12.1: The link is not set to a value

* Error: The link is not set to a value
* e.resolve (http://localhost:8081/main.180bf244e42bb828787d.hashedasset.js:1:521840)
* t.get (http://localhost:8081/main.180bf244e42bb828787d.hashedasset.js:1:518719)
* t.list (http://localhost:8081/main.180bf244e42bb828787d.hashedasset.js:1:22935)
* t.<anonymous> (http://localhost:8081/infrastructure.f2a0c1efc35a0cc36267.hashedasset.js:1:493686)
* o (http://localhost:8081/infrastructure.f2a0c1efc35a0cc36267.hashedasset.js:1:492316)
* (http://localhost:8081/infrastructure.f2a0c1efc35a0cc36267.hashedasset.js:1:491651)
* http://localhost:8081/infrastructure.f2a0c1efc35a0cc36267.hashedasset.js:1:491560
* A (http://localhost:8081/vendor.e8194790042988d73b99.hashedasset.js:38:2371)
* new H (http://localhost:8081/vendor.e8194790042988d73b99.hashedasset.js:38:3660)
* n (http://localhost:8081/infrastructure.f2a0c1efc35a0cc36267.hashedasset.js:1:491343)

I have upgraded to v2018.12.1 since then to see if that would resolve the issue however there was no change.

The config diagnostics page says there have been no recent errors and I could not identify anything interesting in the system diagnostics report. I did notice that the license page is not displaying the number of deployment targets used and mentions that the license limits have been exceeded. I have a grandfathered community license and can’t remember the exact terms but with only 3 deployment targets I wouldn’t expect this to be the case.

Any idea where I should look next?

Kind Regards,

This issue seems to have resolved itself without me taking any further action after a few hours.

Hi @BenAlink,

Thanks for getting in touch, and I’m glad to see that this issue has resolved itself.

Looking at where the error occurred my first guess at a cause would be client side caching. Are you able to let me know if at any point during this process did you perform a hard refresh in your browser (or tried an alternate browser)?

Thanks Ben, let me know if there is anything else we can help with!


Hi Alex,

I don’t think I attempted a hard refresh or another browser so that could very well have been the case. Everything has worked since and the license page is correctly displaying the type of license and number of deployment targets now, no more license limit warnings either.

Hi Ben,

Thanks for the update and glad to hear that the issue hasn’t reoccured and all is well.

Let me know if there is anything else that I can assist with,


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.