Accessing API throws 404 "The resource you requested was not found."


Undocumented Error: Not Found

“ErrorMessage”: “The resource you requested was not found.”
Response headers
content-security-policy: default-src ‘none’; connect-src ‘self’; font-src ‘self’; img-src data: ‘self’; script-src eval: inline: ‘self’ ‘unsafe-eval’ ‘unsafe-inline’; style-src inline: ‘self’ ‘unsafe-inline’; worker-src ‘self’; block-all-mixed-content; sandbox allow-same-origin allow-scripts allow-forms allow-popups allow-modals;
content-type: application/json; charset=utf-8
date: Tue, 26 May 2020 16:42:16 GMT
octopus-node: name=********* ; version=2019.13.7
referrer-policy: no-referrer
server: Microsoft-HTTPAPI/2.0
transfer-encoding: chunked
x-content-type-options: nosniff
x-frame-options: DENY
x-xss-protection: 1; mode=block

Hi @davidkaren26,

Could you please give me a bit more information on the origin of the error? What are you attempting to do when the error occurs?


Thank you @jeremy.miller ! Appreciate your response. I think I found the problem not sure why but in swagger it shows base URL “/octopus” but in API it doesn’t allow “/octopus”. Without “”/octopus" in URL I was able to call API’s.

Hey @davidkaren26,

I’m glad to hear that you got it worked out. Thanks for the update.

I’ve tried to reproduce this behavior in a few ways with no success. By chance do you have a reverse proxy or load balancer in front of your octopus sever?


No we don’t have any @jeremy.miller .

Thanks for the info. I’m gonna dig in to this some more and try to figure out why the base url has “Octopus” in it for you.

Thank you @jeremy.miller !

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.