Access to the path 'C:\Program Files\Octopus Deploy\Octopus\Calamari.3.3.1.tar.gz' is denied

I recently upgraded to 3.3.2, and I cannot get a Mac OS X deployment target to upgrade Calamari. I get the following error:

Access to the path ‘C:\Program Files\Octopus Deploy\Octopus\Calamari.3.3.1.tar.gz’ is denied.

I checked that path on the Octopus Deploy server and there isn’t a Calamari .tar.gz file. I see a nupkg and an Azure nupkg. Octopus will not allow us to deploy to the OS X target until Calamari is upgraded.



I’m sorry you’re experiencing this issue.

The Calamari tar file doesn’t initially exist. It is created when an SSH target is being deployed to. It seems as if the Octopus Service account doesn’t have permission to access that path.

Could you possibly attach the task log?

Is your Octopus Service running as LocalSystem or a custom account?


Sorry I didn’t notice a reply and ended up manually updating last time. I ran into this again today when trying to upgrade to 3.3.14. Our Octopus server is running under a custom service account. I can grant explicit permissions to C:\Program Files\Octopus Deploy\Octopus\ for the service account, but I assumed any generated files would go in the defined “Home Directory” which we have set up on a separate disk.

ServerTasks-22025.log.txt (3 KB)

Yes, I can see why you would assume that. Perhaps it should.

The Calamari package lives in the install directory (C:\Program Files...) as a NuGet package. Before pushing to an SSH target for the first time, we convert it a tar file in the same location.

I think the only option currently is to give the account access to the install directory, otherwise you will run into the same error each time you upgrade.