Access package in the Library

I am using TeamCity to create packages. I have gotten to the point that the NuGet package shows in the c:\Octopus\Packages\MyProject folder correctly.

Now, I need to add it to my deploy step in Octopus. To do that, I believe I need to add it to the Library?

I just can’t figure out how to do that. I don’t want to add it manually, as I think that will just keep that version. I would like to have the current version available. And yes, the NuGet packages for my website are being versioned correctly.

Thank you

Oh, I should mention that I’m using this setting in TeamCity, that is placing the NuGet package in the Octopus\packages directory…


Both TeamCity and Octopus deploy are fine to be on the same machine.

Any suggestions would be welcome.

I did try using the Octopus publishing setting, with the API key, but could not find where the package went to.

Thank you!

Hi Ed,

Thanks for getting in touch! We do not recommend using the Publish Package to FileShare method when using our internal repository. The issue is that we do not monitor the directory so the only way to trigger the index of the folder is to manually do so.
We recommend using the PublishPackagetoHTTP method instead as it will then correctly index the file into the internal repository. You said you tried this but could not find the file. Did you use the URL from the Library -> Packages page that is listed?

There however is a TeamCity plugin for Octopus if you were not aware that will take care of these commands for you. Here is the documentation:

We also have some great videos that will take you through step A-Z in integration of TeamCity with Octopus you can view here:

Please let me know if you would like anything explained further or if you have any further questions.