A channel ID must be provided to enable automatic release creation

I’m getting this error: http://help.octopusdeploy.com/discussions/problems/42000
Octopus Version: 3.3.17

When I try to add a variable set or modify a project variable I get:
“ErrorMessage”: “There was a problem with your request.”,
“Errors”: [
“A channel ID must be provided to enable automatic release creation.”

I do not have automatic release creation enabled and I can’t do the work around listed in the referenced issue because I don’t have a Automatic Release Creation section in my Process area.


I think I do not have the “Automatic Release Creation” Section because I am not using the build in package repo.

I was able to resolve this by:

  1. Process-> Add Step: Add a step that uses the built in package repository
    –This is so that you get the “Auto Release” section in the process tab.
  2. Go to Process and in Automatic Release Creation section you can now choose Create release checkbox and default channel (choose default) and click save.
  3. Un-check Default release creation
  4. Remove the step you added in step 1.
    Now variables save.


Thanks for reaching out. I’m very sorry to hear you had to go through this whole troubleshooting by yourself.

This is a bug that we fixed in 3.4.1: https://github.com/OctopusDeploy/Issues/issues/2372 . Since that version we no longer retain the “Automatic Release Creation” enabled in the shadows like you experienced.

Apologies for the inconveniences caused by this. Please let us know if there’s anything else we can help with.

Best regards,

Hi Dalmiro,
No problem, thanks for the quick response and the info.