2019.1.4 Cannot change project logo

When trying to save a project logo change, the default logo persists.
We’re not getting an error message or anything, the audit log doesn’t show a change either.

The user has ProjectEdit permission.

Hi @Harald_Smnes_Hanssen,

Thanks for getting in touch! I’ll need to get some additional information form you to help troubleshoot this issue.

I have done some testing on my VM and this feature seems to be working fine. Are you able to open your browsers developer console and attempt to change the logo? Could you attach any errors you may see in the console while performing this action?

Are you able to try a hard refresh in the browser with an empty cache, after attempting to change the logo?

Looking forward to hearing from you and getting to the bottom of this.

Best regards,

I used the console debugger in Microsoft Edge and tried to upload a gif and then a png

First and only error with a gif

I tried looking in the OctopusServer.txt, but there are no entries regarding the image uploads.

Did then a hard reset in Edge

Logged in as a normal user, tried changing the logo image to a gif. Succeded with changing the logo to the gif. However, when I tried to change the logo to a png with a size of 32x32, did not succeed.

List of images I tried, but failed with

The images that were uploaded successfully

I could not see a lot of errors, at least anything that could tell me why things are failing, even when I ran the console debugger in Edge.

The errors were rather random.
The BAD REQUEST error popped up after a hard reset in the web browser.

Hi @Harald_Smnes_Hanssen,

Thanks for the extra information here, and the attached images. I have done some testing on my end using Edge and I’m seeing this issue. However, it is oddly intermittent. One project worked after about 4 attempts to upload the same logo, whereas another would not work at all. I am also not seeing any obvious errors in my browser.

Have you tried this in another browser? Chrome/Firefox?

Would you be able to let me know if you experience the same in the above browsers, and if they report any errors in the console?

I am going to check with the team and see if we can identify what could be going wrong here, in the meantime, the above information could be helpful. :slight_smile:

Looking forward to hearing from you.

Best regards,

I’ve gotten the same result in other browsers.
And there are no errors that indicates what is wrong.

I have a feeling that perhaps the folder permissions after upgrading to Spaces, aren’t set properly.
Which could explain the lack of feedback in the logs and in the browser console.

By the way, what are the differences between these two icons in the Project settings view?

Also noted that a project is missing its logo.
I looked up the LogoAttachmentKey id for the project in the database, then looked in the Artifacts folder for project but the referenced file couldn’t be found.

Perhaps something went wrong during the upgrade?

Same issue in 2019.2.2

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.