2.4.2 - Bug - Step template and password issues

I created a step template to deploy a Windows Service; it uses a custom account. Even though I have set the password in the template, it will not apply to any projects that use this step. I have tried changing the password and saving, but to no avail.

Create a new step template for deploying a Nuget Package
Check the feature to deploy a Windows Service
Change the user setting to be a custom account and enter the username and set the password

Once you enter all the details and save, when using this template on a project, the service can’t start because the password is bad. All I have to do to get the service to start is to manually log in, set the password on the service, and then start it.

This issue is happening with IIS sites too, when the app pool is running under a custom account. Basically, the password is not being carried over from the step templates

Thanks Josh and sorry about this, we’ll fix this in a 2.4.3 release!